【筆記】為什麼WordPress不能更新或是安裝新的外掛? 因為php curl!

By | 2017-01-16

 

wordpress是PHP偶齁偶齁出來的,自然需要PHP的大力協助! 而無論是wordpress的更新,或是安裝新的外掛,都會需要php_curl。

下面所談的設定前提為【你可以操作伺服器】為前提,

如果wordpress是服務商提供的伺服器,只能用cpanel之類的

那你去跟主機商幹一架比較快。

 

好,這裡說的環境為 windows + apache2.4 + php5.6的設定curl

 

首先把你php資料夾下的

  • libssh2.dll
  • php_curl.dll (他是在php/ext 資料夾底下)
  • ssleay32.dll
  • libeay32.dll

這四隻檔案複製到Windows\system32裡面

 

然後把

  • libssh2.dll

他複製到Apache24\bin裡面

最後,重啟apache,完工。

 

不要問我為什麼,他是這樣講的: http://stackoverflow.com/questions/30542788/enabling-curl-with-php-5-6-on-windows-8

有問題問他就對了(欸!)

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *